用語集
用語集
50件のツールの解説で使われている用語121件を、分野別にまとめました。説明は各ツールの解説の冒頭の一文で、出典もあわせて示します。
分野から探す
用語の定義は、各ツールが解説に載せている内容です。詳細や例外は、それぞれのツールと出典ページでご確認ください。
JSONの用語
分野のガイド- 2 文字形と 6 文字形、サロゲートペア
- \n や \t のような 2 文字形は 8 種類だけです。掲載ツール: JSON のエスケープ文字の可視化 / このツールの出典: www.rfc-editor.org(出典一覧)
- JSON Lines の規則
- jsonlines.org は、文字コードは UTF-8、各行は 1 つの有効な JSON 値、行の区切りは \n(LF)としています。掲載ツール: JSON Lines の変換 / 本文が示す出典: JSON Lines
- JSON Lines への変換
- 貼り付けた JSON の最上位が配列のとき、要素を 1 つずつ 1 行に書き出します。掲載ツール: JSON Lines の変換 / このツールの出典: jsonlines.org、www.rfc-editor.org(出典一覧)
- JSON Pointer の書き方
- RFC 6901 3 節では、JSON Pointer は 0 個以上の「/ とそれに続く名前」の並びです。掲載ツール: JSON Pointer での値の抽出 / このツールの出典: www.rfc-editor.org(出典一覧)
- エラーの位置と原因
- 最初に見つかった構文エラーで止め、その位置を何行目の何文字目(1 から数える)で示し、前後 12 文字を添えます。掲載ツール: JSON の整形と構文チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- ケース変換の語の分け方
- キーを、_ や - や空白の区切りと、小文字から大文字への切り替わり、連続する大文字、数字の並びで語に分けます。掲載ツール: JSON のキーの一括改名 / このツールの出典: www.rfc-editor.org(出典一覧)
- パスの書き方(JSON Pointer)
- RFC 6901 は、JSON の中の場所を、/ で始まる参照トークンをつないだ文字列で表すとしています。掲載ツール: JSON の差分のパス表示 / このツールの出典: www.rfc-editor.org(出典一覧)
- 引用符のつけ方
- RFC 4180 2 節の 6 は、改行・二重引用符・カンマを含む値は二重引用符で囲むとしています。掲載ツール: JSON から CSV への列展開 / このツールの出典: www.rfc-editor.org(出典一覧)
- 何を比べるか
- 両方の JSON を読み、オブジェクトの項目を「$.user.name」のようなパスにして、パスごとに値の型を集めます。掲載ツール: API の欠けたフィールドの比較 / このツールの出典: www.rfc-editor.org(出典一覧)
- 改名の方法
- オブジェクトのキーを、配列の中も含めて全階層で調べます。掲載ツール: JSON のキーの一括改名 / このツールの出典: www.rfc-editor.org(出典一覧)
- 警告と情報の分け方
- 重複した項目の値がすべて同じなら情報、値が違うなら警告にします。掲載ツール: JSON の重複キーの検出 / このツールの出典: www.rfc-editor.org(出典一覧)
- 出現率が 100% でない項目と、null を除いて 2 種類以上の型が混ざる項目は警告にします。掲載ツール: JSON 配列のキー出現率 / このツールの出典: www.rfc-editor.org(出典一覧)
- 警告にするもの
- 同じオブジェクトの中で項目名が重複している場合(RFC 8259 4 節は一意であるべきとし、重複時の扱いは読み込む側で異なる)と、2 の 53 乗から 1 を引いた値を超える整数(倍精度の数値で読むと丸められる)を警告にします。掲載ツール: JSON の整形と構文チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- 差の判定
- オブジェクトは項目名ごと、配列は同じ位置の添字ごとに比べます。掲載ツール: JSON の差分のパス表示 / このツールの出典: www.rfc-editor.org(出典一覧)
- 取り出し方の規則
- RFC 6901 4 節に従い、左から順に辿ります。掲載ツール: JSON Pointer での値の抽出 / このツールの出典: www.rfc-editor.org(出典一覧)
- 読み方
- RFC 8259 の文法どおりに 1 文字ずつ読みます。掲載ツール: JSON の整形と構文チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- 配列の扱い
- 既定では配列の全要素を 1 つにまとめ、パスの途中を [] と書きます。掲載ツール: API の欠けたフィールドの比較 / このツールの出典: www.rfc-editor.org(出典一覧)
- 配列への変換
- 各行を RFC 8259 の文法で読み、1 行ずつ検査します。掲載ツール: JSON Lines の変換 / このツールの出典: jsonlines.org、www.rfc-editor.org(出典一覧)
- 必須のエスケープと任意のエスケープ
- RFC 8259 7 節は、二重引用符・逆スラッシュ・U+0000 から U+001F までの制御文字は必ずエスケープするとしています。掲載ツール: JSON のエスケープ文字の可視化 / このツールの出典: www.rfc-editor.org(出典一覧)
- 名前の重なり
- RFC 8259 4 節では、オブジェクトの名前は一意であるべきで、重なると読み取り側の挙動が予測できないとされています(最後だけを採る、エラーにする、すべて残すなど)。掲載ツール: JSON のキーの一括改名 / このツールの出典: www.rfc-editor.org(出典一覧)
- 列の作り方
- 配列の要素のオブジェクトを順に読み、入れ子のオブジェクトの項目はドット区切りのパス(address.city など)を列名にします。掲載ツール: JSON から CSV への列展開 / このツールの出典: www.rfc-editor.org(出典一覧)
CSV・表データの用語
分野のガイド- 1900 年の閏年の扱い
- Excel は 1900 年を閏年として扱います(Lotus 1-2-3 との互換のため。掲載ツール: Excel の日付シリアル値の変換 / このツールの出典: learn.microsoft.com、support.microsoft.com(出典一覧)
- 2 つの日付システム
- Excel の日付は、ある基準日からの日数(シリアル値)で保存されます。掲載ツール: Excel の日付シリアル値の変換 / このツールの出典: learn.microsoft.com、support.microsoft.com(出典一覧)
- BOM と Shift_JIS の確認
- 先頭の EF BB BF は UTF-8 の BOM で、UTF-8 として読むときは読み捨てられます(6.1・6 節)。掲載ツール: CSV の文字化けの診断 / このツールの出典: encoding.spec.whatwg.org(出典一覧)
- UTF-8 として読めるかの判定
- WHATWG Encoding Standard 8.1.1 の UTF-8 decoder の規則で、バイト列を 1 つずつ確かめます。掲載ツール: CSV の文字化けの診断 / このツールの出典: encoding.spec.whatwg.org(出典一覧)
- W3C の trim との関係
- W3C の表データの仕様では、dialect の trim でセルの前後の空白を取り除くかを指定でき、既定は取り除く設定です。掲載ツール: CSV の空白だけのセルの検出 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- エラー・警告にする条件
- 値の数が見出しの行(見出しがない場合は最も多い値の数)と違う行と、最後まで閉じていない引用符はエラーです。掲載ツール: CSV の列ずれ・空欄・重複チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- ゼロ埋めと桁数
- 001 と 1 は数値として同じ 1 として比べます。掲載ツール: 注文番号の欠番チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- どの改行を変えるか
- RFC 4180 2 節の 1 は、レコードを改行(CRLF)で区切ると定めています。掲載ツール: CSV の改行コードの統一 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 引用符の中の改行
- RFC 4180 2 節の 6 により、改行を含む値は二重引用符で囲みます。掲載ツール: CSV の改行コードの統一 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 区切り位置
- 固定電話の市外局番の桁数(2〜4 桁)は、番号の指定一覧がないと決められません。掲載ツール: 電話番号の国内表記の統一 / このツールの出典: 総務省(出典一覧)
- 警告にする条件
- 空欄率がしきい値以上で空欄が 1 つ以上ある列、空欄以外の値がすべて数字なのに文字数が 2 種類以上ある列、すべての行が空欄の列を警告にします。掲載ツール: CSV の列プロファイル / このツールの出典: www.rfc-editor.org(出典一覧)
- 欠番と重複の定義
- 接頭辞ごとに、見つかった番号の最小から最大までのあいだで、列に 1 度も現れない整数を欠番とし、連続する欠番は「1005 〜 1007」のように区間にまとめます。掲載ツール: 注文番号の欠番チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- 候補の条件
- PostgreSQL では PRIMARY KEY は UNIQUE と NOT NULL を合わせた制約で、値が重複せず、空(NULL)もない列または列の組が対象です。掲載ツール: CSV の主キー候補のチェック / このツールの出典: www.postgresql.org、www.rfc-editor.org(出典一覧)
- 国内表記にそろえる手順
- 全角の数字・ハイフン・括弧・空白を半角にそろえ、ハイフン・括弧・空白・ドットを取り除いて数字だけにします。掲載ツール: 電話番号の国内表記の統一 / このツールの出典: 総務省(出典一覧)
- 最後の行の改行
- RFC 4180 2 節の 2 は、最後のレコードの改行はあってもなくてもよいとしています。掲載ツール: CSV の改行コードの統一 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 時刻と上限
- 小数点以下は 1 日を 1 とした時刻の割合で、0.5 は 12:00:00 です。掲載ツール: Excel の日付シリアル値の変換 / このツールの出典: learn.microsoft.com、support.microsoft.com(出典一覧)
- 集計表の見方
- 列ごとに見出し、値のある行の数、空欄の数、空欄のある行番号(先頭 5 件)を表にします。掲載ツール: CSV の列ずれ・空欄・重複チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- 対象にする空白
- 半角スペース(U+0020)・全角スペース(U+3000)・タブ(U+0009)・NBSP(U+00A0)・改行(引用符の中のもの)だけで 1 文字以上あるセルを対象にします。掲載ツール: CSV の空白だけのセルの検出 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 長さの分布と内容
- 長さは元の値の文字数(絵文字などは 1 文字)で、空欄を除いた値について、最短・最長と、文字数ごとの件数を多い順に示します。掲載ツール: CSV の列プロファイル / このツールの出典: www.rfc-editor.org(出典一覧)
- 貼り付けたテキストの化け方
- ファイルがなく文字だけを貼り付けたときは、すでに置き換わった U+FFFD の数と位置、UTF-8 を Latin-1 系で読んだときの「
é」のような並び、UTF-8 のひらがなを Shift_JIS で読んだときに多い「縺」「繧」「繝」を数えます。掲載ツール: CSV の文字化けの診断 / このツールの出典: encoding.spec.whatwg.org(出典一覧) - 読み方
- RFC 4180 の 2 節に沿って読みます。掲載ツール: CSV の列ずれ・空欄・重複チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- 判定の基準
- 総務省の電気通信番号の指定状況にある構造に沿い、固定電話は先頭の 0 + 市外局番 + 市内局番 + 加入者番号 4 桁で、市外局番と市内局番を合わせて 5 桁、先頭の 0 を含め 10 桁とします。掲載ツール: 電話番号の国内表記の統一 / 本文が示す出典: 総務省 電気通信番号の指定状況
- 判定の限界
- 判定はこの CSV に含まれる行だけで行います。掲載ツール: CSV の主キー候補のチェック / このツールの出典: www.postgresql.org、www.rfc-editor.org(出典一覧)
- 番号の読み方
- CSV は RFC 4180 の 2 節に沿って読み、選んだ列の値の末尾に続く数字(15 桁まで)を番号とします。掲載ツール: 注文番号の欠番チェック / このツールの出典: www.rfc-editor.org(出典一覧)
SQL・XMLの用語
分野のガイド- エラーにするもの
- 宣言されていない接頭辞の使用(5 節)、xmlns:接頭辞="" による宣言解除(XML 1.0 では禁止)、接頭辞 xmlns の宣言と接頭辞 xml の別の名前への結び付け、予約された名前空間の取り違えをエラーにします。掲載ツール: XML の名前空間の一覧 / このツールの出典: www.w3.org(出典一覧)
- 引用符と大文字小文字
- 二重引用符で囲んだ名前は予約語ではなく、予約語と同じ綴りでも使えます。掲載ツール: SQL の予約語の列名チェック / このツールの出典: www.postgresql.org(出典一覧)
- 関係の記号の決め方
- REFERENCES の参照先を親、参照する表を子として、親 記号 子 : 列名 の形で書きます。掲載ツール: CREATE TABLE から ER 図 / このツールの出典: mermaid.js.org、www.postgresql.org(出典一覧)
- 行と列の作り方
- 繰り返し要素の 1 つを 1 行にします。掲載ツール: XML の繰り返し要素の表への変換 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 実線と破線
- Mermaid では実線 -- が識別関係、破線 .. が非識別関係を表します。掲載ツール: CREATE TABLE から ER 図 / このツールの出典: mermaid.js.org、www.postgresql.org(出典一覧)
- 実体参照と CDATA
- DTD がない XML で使える実体は & < > ' " の 5 つで、数値による文字参照(あ など)も文字に直します。掲載ツール: XML の繰り返し要素の表への変換 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 数値・空欄の扱い
- 0 と 1〜9 で始まる整数、小数点以下がある数、指数つきの数は 4.1.2.6 の数値定数の形なので引用符なしで出力します。掲載ツール: CSV から INSERT 文の生成 / このツールの出典: www.postgresql.org、www.rfc-editor.org(出典一覧)
- 整形式の検査
- XML 1.0 の整形式の規則に沿って読みます。掲載ツール: XML の繰り返し要素の表への変換 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 宣言と適用範囲
- 名前が xmlns の属性は既定の名前空間を、xmlns:接頭辞 の属性はその接頭辞を、名前空間に結び付けます。掲載ツール: XML の名前空間の一覧 / このツールの出典: www.w3.org(出典一覧)
- 属性の扱い
- 既定の名前空間は要素にだけ適用され、接頭辞のない属性は名前空間なしです(6.2 節)。掲載ツール: XML の名前空間の一覧 / このツールの出典: www.w3.org(出典一覧)
- 読み取る範囲
- コメント(-- と /* */)・単一引用符の文字列・ドル引用符の文字列・二重引用符つきの名前は、1 つのまとまりとして読み飛ばします。掲載ツール: SQL の予約語の列名チェック / このツールの出典: www.postgresql.org(出典一覧)
- 判定の根拠
- PostgreSQL のドキュメント付録 C は、キーワードを予約語と非予約語などに分けています。掲載ツール: SQL の予約語の列名チェック / このツールの出典: www.postgresql.org(出典一覧)
- 表と列の読み方
- 各 CREATE TABLE の括弧の中をカンマで分け、PRIMARY KEY・UNIQUE・CHECK・FOREIGN KEY などの表の制約を除いた項目の先頭を列名、続く語を型とします。掲載ツール: CREATE TABLE から ER 図 / このツールの出典: mermaid.js.org、www.postgresql.org(出典一覧)
- 文字列の作り方
- PostgreSQL の文字列定数は単一引用符で囲み、値の中の単一引用符は 2 つ重ねて書きます(ドキュメント 4.1.2.1)。掲載ツール: CSV から INSERT 文の生成 / このツールの出典: www.postgresql.org、www.rfc-editor.org(出典一覧)
- 列名・表名の作り方
- 引用符なしの名前は小文字に畳まれ、二重引用符で囲んだ名前は大文字小文字を区別します(4.1.1)。掲載ツール: CSV から INSERT 文の生成 / このツールの出典: www.postgresql.org、www.rfc-editor.org(出典一覧)
HTTP ヘッダーと安全の点検の用語
分野のガイド- 2 桁の年
- rfc850-date の年は 2 桁です。掲載ツール: Retry-After の時刻換算 / このツールの出典: datatracker.ietf.org、www.rfc-editor.org(出典一覧)
- HSTS の判定
- max-age は必須で秒数の整数(引用符つきも可)、各ディレクティブは 1 回だけ、includeSubDomains は値をとらないフラグです(RFC 6797 6.1)。掲載ツール: セキュリティヘッダーの点検 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- RateLimit 系ヘッダー(草案)
- RateLimit-Policy は q(割り当て)・qu(単位)・w(期間の秒数)、RateLimit は r(残り)・t(回復までの秒数)を持ちます。掲載ツール: Retry-After の時刻換算 / このツールの出典: datatracker.ietf.org、www.rfc-editor.org(出典一覧)
- Retry-After の読み方
- 値が数字だけなら delay-seconds(待つ秒数)、HTTP-date の 3 形式(IMF-fixdate・rfc850-date・asctime-date)のどれかなら日時として読みます(RFC 9110 10.2.3 節・5.6.7 節)。掲載ツール: Retry-After の時刻換算 / このツールの出典: datatracker.ietf.org、www.rfc-editor.org(出典一覧)
- エラー・警告にする条件
- 秒数が整数でない・必要な秒数がない・指示名に使えない文字がある・引用符が閉じていない場合はエラーです。掲載ツール: Cache-Control の読み解き / このツールの出典: www.rfc-editor.org(出典一覧)
- エラーにする条件
- Allow-Origin がない、複数ある、オリジンの形でない(末尾の / など)、資格情報つきで * になっている、資格情報つきで Allow-Credentials が true(小文字)でない場合は、ブラウザの CORS チェックが失敗するのでエラーにします(3.3.4・3.3.5・4.10 …掲載ツール: CORS ヘッダーの差分比較 / このツールの出典: fetch.spec.whatwg.org(出典一覧)
- 名前に英数字とハイフン以外が使われている(コンマ区切りの誤りなど)、'none' がほかのソース式と同居している、nonce・ハッシュの書式が正しくない、キーワードでもスキームでもホストでもないソース式がある、meta 要素で使えない report-uri・frame-ancestors・sandb…掲載ツール: CSP のディレクティブ一覧 / このツールの出典: www.w3.org(出典一覧)
- 名前=値の「=」がない・名前が空(ブラウザは Set-Cookie 全体を無視。掲載ツール: Set-Cookie の属性の点検 / このツールの出典: datatracker.ietf.org、www.rfc-editor.org(出典一覧)
- 警告・情報にする条件
- 資格情報つきの Allow-Methods・Allow-Headers・Expose-Headers の * は、ワイルドカードにならず「*」という名前そのものになるため警告にします。掲載ツール: CORS ヘッダーの差分比較 / このツールの出典: fetch.spec.whatwg.org(出典一覧)
- ディレクティブの重複、値が空のソースリスト、引用符のないキーワード(self と書いたものはホスト名扱い)は警告です。掲載ツール: CSP のディレクティブ一覧 / このツールの出典: www.w3.org(出典一覧)
- 整数でない Max-Age・400 日を超える寿命・RFC 1123 でない Expires・不正な SameSite の値・重複した属性や名前・値に使えない文字は警告にします。掲載ツール: Set-Cookie の属性の点検 / このツールの出典: datatracker.ietf.org、www.rfc-editor.org(出典一覧)
- 警告にする条件
- ハイフンの数や空白、小文字の BEGIN など RFC の形から外れた境界行(読み取る側が許容して鍵として使えることがあります)、END 行がない・END のラベルが BEGIN と違う、本体が空か base64 以外の文字を含む場合は警告です。掲載ツール: 秘密鍵らしい形式の検出 / このツールの出典: www.rfc-editor.org(出典一覧)
- 読み方
- 値をカンマで指示に分け(引用符の中のカンマは区切らない)、指示名は大文字・小文字を区別せずに RFC 9111 の 5.2 節と、拡張として RFC 8246(immutable)・RFC 5861(stale-while-revalidate・stale-if-error)に照らして意味を表にしま…掲載ツール: Cache-Control の読み解き / このツールの出典: www.rfc-editor.org(出典一覧)
- A と B の各行を「ヘッダー名: 値」に分け、Fetch Standard 3.3 節が定める 6 つの応答ヘッダー(Allow-Origin・Allow-Credentials・Allow-Methods・Allow-Headers・Max-Age・Expose-Headers)だけを比べます。掲載ツール: CORS ヘッダーの差分比較 / このツールの出典: fetch.spec.whatwg.org(出典一覧)
- 値を「;」でディレクティブに分け、各ディレクティブを空白で名前と値に分けます。掲載ツール: CSP のディレクティブ一覧 / このツールの出典: www.w3.org(出典一覧)
- 各行を「;」で分け、先頭を「名前=値」、残りを属性として読みます。掲載ツール: Set-Cookie の属性の点検 / このツールの出典: datatracker.ietf.org、www.rfc-editor.org(出典一覧)
- 貼り付けた各行を「名前: 値」に分け、名前の大文字・小文字を区別せずに Strict-Transport-Security・Referrer-Policy・Permissions-Policy を探します。掲載ツール: セキュリティヘッダーの点検 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 文章を行に分け、RFC 7468 3 節の境界行「-----BEGIN ラベル-----」を探します。掲載ツール: 秘密鍵らしい形式の検出 / このツールの出典: www.rfc-editor.org(出典一覧)
- 判定の範囲
- この点検は構文とソース式の形、仕様に書かれた組み合わせを機械的に確かめるだけです。掲載ツール: CSP のディレクティブ一覧 / このツールの出典: www.w3.org(出典一覧)
- この点検は書式と属性の組み合わせを機械的に確かめるだけです。掲載ツール: Set-Cookie の属性の点検 / このツールの出典: datatracker.ietf.org、www.rfc-editor.org(出典一覧)
- 判定するのはヘッダーの有無・構文・値の解釈だけです。掲載ツール: セキュリティヘッダーの点検 / このツールの出典: www.rfc-editor.org、www.w3.org(出典一覧)
- 探すのは PEM 形式の秘密鍵の境界行だけです。掲載ツール: 秘密鍵らしい形式の検出 / このツールの出典: www.rfc-editor.org(出典一覧)
- 秘密鍵とみなすラベル
- RFC 7468 が定義する PRIVATE KEY(10 節)と ENCRYPTED PRIVATE KEY(11 節)に加え、末尾が PRIVATE KEY のラベル(RSA PRIVATE KEY など)を、広く使われる慣用ラベルとして秘密鍵らしいものに含めます。掲載ツール: 秘密鍵らしい形式の検出 / このツールの出典: www.rfc-editor.org(出典一覧)
- 要約の見方
- レスポンスのときは、ブラウザ(個人用キャッシュ)と CDN・プロキシ(共有キャッシュ)のそれぞれについて、保存するか・確認なしで使える期間を一文にまとめます。掲載ツール: Cache-Control の読み解き / このツールの出典: www.rfc-editor.org(出典一覧)
API・curlの用語
分野のガイド- パスの照合
- 観測したパスは、文書の paths のキーと完全に一致するものを先に探し、なければ {id} のようなテンプレート部分を 1 区間の任意の文字に置き換えて照合します。掲載ツール: OpenAPI にない HTTP ステータスの抽出 / このツールの出典: spec.openapis.org(出典一覧)
- ヘッダー・ボディ・認証
- ヘッダーは -H で追加します。掲載ツール: curl コマンドの生成 / このツールの出典: curl.se(出典一覧)
- メソッドの書き方
- GET は何も付けず、HEAD は -I を使います(-X HEAD ではヘッダーだけの取得になりません)。掲載ツール: curl コマンドの生成 / このツールの出典: curl.se(出典一覧)
- 引用と指摘
- 各値は POSIX シェルの一重引用符で囲み、値の中の一重引用符は '\'' に置き換えます。掲載ツール: curl コマンドの生成 / このツールの出典: curl.se(出典一覧)
- 往復の区切り
- 「GET /path HTTP/1.1」のような要求行が現れるたびに、新しい往復として番号を進めます。掲載ツール: curl -v のログのヘッダー整理 / このツールの出典: curl.se(出典一覧)
- 行頭の記号の意味
- curl -v のログでは、行頭の > は curl が送ったヘッダー、< は curl が受け取ったヘッダー、* は curl の追加情報、{ と } はデータの送受信を表します(curl 公式マニュアルの --verbose)。掲載ツール: curl -v のログのヘッダー整理 / このツールの出典: curl.se(出典一覧)
- 参照と無視されるヘッダー
- パラメータは $ref(Reference Object)で components の定義を参照できます。掲載ツール: OpenAPI の必須パラメータの一覧 / このツールの出典: spec.openapis.org(出典一覧)
- 指摘の意味
- 未定義のコード、文書にない操作、responses がない操作、書き方が仕様と違うキー(小文字の 4xx など)は警告です。掲載ツール: OpenAPI にない HTTP ステータスの抽出 / このツールの出典: spec.openapis.org(出典一覧)
- データが 20 件未満のときは、高い百分位が最大値に近くなる旨を情報で示します。掲載ツール: 応答時間の百分位点の集計 / このツールの出典: www.itl.nist.gov(出典一覧)
- 認証情報を伏せる
- Authorization・Proxy-Authorization・Cookie・Set-Cookie は、値にトークンやセッション ID を含むため、既定では値を伏せて表示します。掲載ツール: curl -v のログのヘッダー整理 / このツールの出典: curl.se(出典一覧)
- 判定の順序
- OpenAPI 3.1.0 の Responses Object では、キーに 3 桁のコード(200 など)、1XX〜5XX の範囲(X は大文字)、default を書けます。掲載ツール: OpenAPI にない HTTP ステータスの抽出 / このツールの出典: spec.openapis.org(出典一覧)
- 必須になる条件
- OpenAPI 3.1.0 の Parameter Object では、in が path のパラメータは required: true が必須で、ほかの場所(query・header・cookie)は required が省略されると false になります。掲載ツール: OpenAPI の必須パラメータの一覧 / このツールの出典: spec.openapis.org(出典一覧)
- 百分位点の求め方(NIST の定義)
- データを小さい順に並べた件数を N とし、求める割合 p に対して p(N+1) を整数部 k と小数部 d に分けます。掲載ツール: 応答時間の百分位点の集計 / このツールの出典: www.itl.nist.gov(出典一覧)
- 別の定義との差
- 表計算の PERCENTILE.INC などは、位置を 1 + p(N-1) として同じように線形補間します。掲載ツール: 応答時間の百分位点の集計 / このツールの出典: www.itl.nist.gov(出典一覧)
URL・リンク・転送の用語
分野のガイド- ASCII の扱い
- %20(空白)や %2F(スラッシュ)などの ASCII は、アドレスの区切りとして意味を持つため、既定では戻しません。掲載ツール: URLに含まれる日本語の可読化 / このツールの出典: encoding.spec.whatwg.org、url.spec.whatwg.org(出典一覧)
- UTF-8 としての復号
- 続く %XX を 1 まとまりのバイト列として読み、WHATWG の Encoding Standard が定める utf-8 decoder と同じ範囲(先頭バイト C2〜F4、継続バイト 80〜BF。掲載ツール: URLに含まれる日本語の可読化 / このツールの出典: encoding.spec.whatwg.org、url.spec.whatwg.org(出典一覧)
- UTM の項目と必須
- Google アナリティクスのヘルプは、UTM を付けるときは utm_source(参照元)・utm_medium(マーケティング媒体)・utm_campaign(キャンペーン名)を常に使うよう案内しています。掲載ツール: UTM パラメータの一括抽出 / このツールの出典: support.google.com、url.spec.whatwg.org(出典一覧)
- クエリの読み方
- クエリは WHATWG URL Standard の 5.1 のとおり、& で区切り、最初の = で名前と値に分け、+ を空白に、パーセントエンコードを UTF-8 の文字に戻して読みます。掲載ツール: UTM パラメータの一括抽出 / このツールの出典: support.google.com、url.spec.whatwg.org(出典一覧)
- クエリの読み方と並べ替え
- クエリは WHATWG URL Standard の 5.1 のとおり、& で区切り、最初の = で名前と値に分け、+ を空白に、%エンコードを UTF-8 として戻して読みます。掲載ツール: URL の表記ゆれの正規化 / このツールの出典: developers.google.com、url.spec.whatwg.org、www.rfc-editor.org(出典一覧)
- ドットセグメントの除去
- ./ と ../ は 5.2.4 の手順で取り除きます。掲載ツール: 相対 URL の絶対化 / このツールの出典: www.rfc-editor.org(出典一覧)
- ハイフンと小文字を選ぶ理由
- Google 検索セントラルの URL 構造のページは、単語の区切りにアンダースコアよりハイフンを使うことを勧めています。掲載ツール: SEO 用スラッグの整形 / このツールの出典: developers.google.com、www.rfc-editor.org(出典一覧)
- 何をしているか
- WHATWG のアドレス仕様(1.3)では、percent-decode は「%」の後に 16 進 2 桁が続く部分をそのバイトに戻す処理、UTF-8 percent-encode は文字を UTF-8 に符号化してから各バイトを「%」+大文字の 16 進 2 桁にする処理と定められています。掲載ツール: URLに含まれる日本語の可読化 / このツールの出典: encoding.spec.whatwg.org、url.spec.whatwg.org(出典一覧)
- 検査する決まり
- sitemaps.org の Sitemap protocol にもとづき、UTF-8 であること、urlset を根にして url の中に loc を書くこと、アドレスの中の & などは & のようにエスケープすること、loc は 2,048 文字未満であること、1 ファイルは 50,00…掲載ツール: サイトマップの URL 検査 / このツールの出典: www.rfc-editor.org、www.sitemaps.org(出典一覧)
- 差分の出し方
- 改修前と改修後の一覧を、ページのアドレスで突き合わせます。掲載ツール: canonical の参照先の差分比較 / このツールの出典: www.rfc-editor.org(出典一覧)
- 指摘にする条件
- 正規化すると同じになるアドレスは警告、大文字小文字だけが違うパスと、末尾のスラッシュの有無だけが違うパスも警告にします。掲載ツール: URL の表記ゆれの正規化 / このツールの出典: developers.google.com、url.spec.whatwg.org、www.rfc-editor.org(出典一覧)
- 循環の考え方(RFC 9110 15.4)
- RFC 9110 の 15.4 は、リダイレクトを辿る側が、永遠に続く循環を検出して止めるべき(SHOULD)としています。掲載ツール: リダイレクトの循環チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- 情報・警告・エラー
- 参照にスキームがあって基準を使わないもの、根より上へ上がろうとした ../ があるものは情報として示します。掲載ツール: 相対 URL の絶対化 / このツールの出典: www.rfc-editor.org(出典一覧)
- 状態コードと比較のしかた
- 301・302・303・307・308 は 15.4.2〜15.4.9 に定められた転送の状態コードで、移転が恒久的か一時的か、メソッドを保つかの違いがあります。掲載ツール: リダイレクトの循環チェック / このツールの出典: www.rfc-editor.org(出典一覧)
- 整え方
- 全角の英数字や記号を半角にそろえ(Unicode の NFKC)、英字を小文字にします。掲載ツール: SEO 用スラッグの整形 / このツールの出典: developers.google.com、www.rfc-editor.org(出典一覧)
- 正規化のしかた
- RFC 3986 の 6.2 に沿って、スキームとホストを小文字にし、http の 80・https の 443 などの既定ポートと空のポートを取り除き、%の後ろの 16 進を大文字にし、英数字と - . _ ~ を表す %エンコードを元の文字に戻し、./ と ../ を整理し、パスが空なら / に…掲載ツール: URL の表記ゆれの正規化 / このツールの出典: developers.google.com、url.spec.whatwg.org、www.rfc-editor.org(出典一覧)
- 対象外のリンク
- 「//example.com/path」のようなプロトコル相対のリンクは、スキームが読み込み元のページで決まるため判定の対象外です。掲載ツール: http のままの内部リンクの抽出 / このツールの出典: url.spec.whatwg.org(出典一覧)
- 値の大文字小文字と表記ゆれ
- UTM の値は大文字小文字が区別され、utm_source=google と utm_source=Google は別の値として集計されます。掲載ツール: UTM パラメータの一括抽出 / このツールの出典: support.google.com、url.spec.whatwg.org(出典一覧)
- 置換案の作り方
- 内部で http のリンクは、スキームを https に替えた案を出します。掲載ツール: http のままの内部リンクの抽出 / このツールの出典: url.spec.whatwg.org(出典一覧)
- 内部リンクの決め方
- 貼り付けた各リンクを「スキーム://ホスト:ポート/残り」に分け、ホストを小文字にして基準のドメインと比べます。掲載ツール: http のままの内部リンクの抽出 / このツールの出典: url.spec.whatwg.org(出典一覧)
- 日本語などの扱い
- ASCII 以外の文字は、Google の説明にあるとおり UTF-8 のパーセントエンコードにできます(gemüse は gem%C3%BCse)。掲載ツール: SEO 用スラッグの整形 / このツールの出典: developers.google.com、www.rfc-editor.org(出典一覧)
- 変換の手順
- RFC 3986 の 5.2.2 の手順で、参照にスキームがあればそのまま絶対のアドレスとして扱い、ホストがあれば基準のスキームだけを使い、パスが空なら基準のパスを使い、/ で始まるパスはそのまま、それ以外は基準の最後の / までに結合します(5.2.3)。掲載ツール: 相対 URL の絶対化 / このツールの出典: www.rfc-editor.org(出典一覧)
- 問題の判定
- 参照先がそのまま一覧のページとして載っていて、その参照先が自分以外を指していれば連鎖です。掲載ツール: canonical の参照先の差分比較 / このツールの出典: www.rfc-editor.org(出典一覧)
- 連鎖の段数
- A から B、B から C のように転送が続くと段数が増えます。掲載ツール: リダイレクトの循環チェック / このツールの出典: www.rfc-editor.org(出典一覧)
ページのマークアップと見た目の用語
分野のガイド- HTML との突き合わせ
- HTML の class 属性を空白で区切って語に分け、CSS のクラス名と文字列として比べます。掲載ツール: CSS の未使用クラス候補の棚卸し / このツールの出典: www.w3.org(出典一覧)
- クラスの取り出し方
- 貼り付けた CSS からコメントと文字列を除き、「{」の直前にあるセレクタの部分から .名前 の形を取り出します。掲載ツール: CSS の未使用クラス候補の棚卸し / このツールの出典: www.w3.org(出典一覧)
- 画面幅の切れ目
- @media の条件にある (min-width: 値) と (max-width: 値) を、px・em・rem の単位つきで一覧にします。掲載ツール: CSS の未使用クラス候補の棚卸し / このツールの出典: www.w3.org(出典一覧)
- 基準と判定の順序
- 達成基準 2.5.8 は、ポインタで操作する対象が幅・高さとも 24 CSS ピクセル以上であることを求めます。掲載ツール: ボタンの押下領域の寸法チェック / このツールの出典: www.w3.org(出典一覧)
- 計算
- 各色の 8 ビットの値を 255 で割り、0.04045 以下なら 12.92 で割り、それ以外は (c + 0.055) ÷ 1.055 の 2.4 乗にして、0.2126・0.7152・0.0722 の重みで足し合わせると相対輝度 L です。掲載ツール: 文字色のコントラスト比の計算 / このツールの出典: www.w3.org(出典一覧)
- 固定ヘッダーの目安
- 固定ヘッダーの高さを入力すると、html の scroll-padding の上側と、飛び先の要素の style 属性にある scroll-margin の上側の合計が、ヘッダーの高さ未満の飛び先を警告します(MDN)。掲載ツール: ページ内リンクのリンク切れ確認 / このツールの出典: developer.mozilla.org、html.spec.whatwg.org(出典一覧)
- 指摘にする条件
- href がない・空は、エラーまたは警告にします。掲載ツール: favicon のサイズの点検 / このツールの出典: developers.google.com、html.spec.whatwg.org(出典一覧)
- 照合の規則
- リンクの # の後ろ(フラグメント)が空なら、ページの先頭に届きます。掲載ツール: ページ内リンクのリンク切れ確認 / このツールの出典: developer.mozilla.org、html.spec.whatwg.org(出典一覧)
- 申告の例外
- Equivalent・Inline・User agent control・Essential の 4 つの例外は、ページの意味や文脈を見ないと判定できません。掲載ツール: ボタンの押下領域の寸法チェック / このツールの出典: www.w3.org(出典一覧)
- 対象外のもの
- ロゴや文字を含む装飾、使えない状態の部品の文字などには基準がありません。掲載ツール: 文字色のコントラスト比の計算 / このツールの出典: www.w3.org(出典一覧)
- 特別な名前
- デコード後の文字列が大文字・小文字を無視して、ページの先頭を表す 3 文字の名前(t・o・p)に一致し、同名の id もなければ、先頭に届く扱いです。掲載ツール: ページ内リンクのリンク切れ確認 / このツールの出典: developer.mozilla.org、html.spec.whatwg.org(出典一覧)
- 読み方
- link 要素の rel を空白で分け、icon・apple-touch-icon・apple-touch-icon-precomposed を含むものをアイコンの宣言として表にします(shortcut icon も icon を含むため対象です)。掲載ツール: favicon のサイズの点検 / このツールの出典: developers.google.com、html.spec.whatwg.org(出典一覧)
- 判定の基準
- 通常の文字は 4.5:1 以上、大きな文字(18pt 以上、または太字で 14pt 以上。掲載ツール: 文字色のコントラスト比の計算 / このツールの出典: www.w3.org(出典一覧)